Dec 16, 2007

Boomerを Cache::Memcached::Fastに対応させる

Cache::Memcached::Fastを試す : blog.nomadscafe.jpで、Cache::Memcached::Fastの存在を知ったので、Boomerを対応させてみた。

オリジナルではCache::Memcachedを使う実装になっているが、上記のパッチは、Cache::Memcached::FastがあればCache::Memcached::Fastを、なければCache::Memcachedを使うように変更する。

効果のほどは試していない不明だが、Cache::Memcachedを使うPure Perlな実装に比べてかなりの高速化が期待できる。Cache::Memcached::Fastで実装されていないAPIもあるので、上記のパッチが正常に動作するかどうかは分からない。

2007-12-20追記:
MemcachedDriverディレクティブで使用するmemcachedドライバを選択できるようにしたパッチも用意した。

mt-config.cgiで下のように指定すればCache::Memcached::Fastが使われる(デフォルトはCache::Memcached)。

MemcachedDriver Cache::Memcached::Fast

Cache::Memcached互換なインタフェースを持つドライバであれば一応何でもOK。

About Me

My Photo

つくばで働く研究者

Total Pageviews

Amazon

Copyright 2012 Ogawa::Buzz | Powered by Blogger
Design by Web2feel | Blogger Template by NewBloggerThemes.com